Storm Éowyn - Ultrafast Connectivity Disruption - Belfast, Cathedral Quarter
Incident Report for Tibus
Resolved
This incident has been resolved.
Posted Jan 24, 2025 - 14:50 GMT
Identified
Due to localised power issues, customers in the Cathedral Quarter area of Belfast may face disruption to their Ultrafast connectivity.
Posted Jan 24, 2025 - 09:26 GMT
This incident affected: Connectivity & Broadband (Cathedral Quarter Area).