Service interruptions in Dublin and London

Incident Report for Tibus

Resolved

This incident has been resolved.
Posted May 16, 2025 - 12:17 BST

Investigating

We are currently investigating this issue.
Posted May 16, 2025 - 11:33 BST
This incident affected: Email Services (IMAP, POP, SMTP, Webmail), Self Service Cloud (Cloud Control Panel, Account Login/Registration Service, Dublin Availability Zone), Managed Hosting Services (Dublin (Managed Hosting), London (Managed Hosting)), and Streaming & Content Delivery (Live Audio Streaming).