Power issues in BT1

Incident Report for Tibus

Resolved

NIE have resolved all local power issues and all affected customers service has restored.
Posted Dec 09, 2022 - 15:48 GMT

Identified

A small number of connectivity and Ultrafast customers in Belfast BT1 are currently offline due to a confirmed NIE power outage in the area. We will monitor these customers until NIE resolve and recovery of services is confirmed.
Posted Dec 09, 2022 - 14:54 GMT
This incident affected: Connectivity & Broadband (Cathedral Quarter Area).