Update from Cloudflare: A fix has been implemented and we are monitoring the results.
Posted Dec 05, 2025 - 09:16 GMT
Identified
Cloudflare is investigating issues with its service. These issues do not affect the serving of cached files via the Cloudflare CDN or other security features at the Cloudflare Edge.
Tibus customers may experience difficulties accessing their sites. The underlying Tibus infrastructure is unaffected.
Posted Dec 05, 2025 - 09:00 GMT
This incident affected: Self Service Cloud (Cloud Control Panel, Account Login/Registration Service), Managed Hosting Services (Dublin (Managed Hosting), London (Managed Hosting)), and Tibus Website.